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1 SOFTWARE INSTALLATION

1. Download the SpectraPen software from PSI website

https://handheld.psi.cz/products/spectrapen-

mini/#download to your computer and launches the

SpectraPen program.

2. Toactivate all software features register the SpectraPen

software as follows (Fig. 1).
e Select: Help > Register
. Enter serial registration number,
available in download section on PSI website
e Select: OK

which is

File Device Setup | Help
> Registration 7
About
Online Commands
Registration
Input your code:

[ Regster ] [ Cancel |

Fig. 1 Software registration.

It is not possible to download data from the SpectraPen device without software registration.

2 DATA TRANSFER

For data transfer from mobile application to your computer select Share and choose your preferred option (Fig. 2).

Photon
Systems
Instruments

|8 Spectrometer
1.50
ﬁ Light meter
Share
&a Dark Calibration

¢ Connections Save to Drive
©  Avou

1]
[O =" Android

Beam

Version: 0.9.44

SPECTROMETER

1.00

SpectraPen

LIGHT METER

Link Sharing
Share large files up to 2 GB per day.

® o n

Email Add to Add to Maps
Dropbox
Bluetooth Gmail Google+

Fig. 2 Data export and sharing via available communication channels.

SpectraPen

SPECTROMETER LIGHT METER

’3) Link Sharing

& Share large files up to 2 GB per day.

OneDrive OneNote Samsung Samsung
Cloud Drive  Print Servic...

A

Upload to
Photos

Wi-Fi Direct

It is not possible to download data from the SpectraPen device without software registration.
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Open your data in .spec format using the SpectraPen software (Fig. 3).

@ SpectraPen

File Device Setup Help

Download
g f
Open
oo

Save

Export

Device: Not Connected ‘ Version

Fig. 3 Opening data in SpectraPen software.
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3 SOFTWARE MENU

MENU: File
Load Loads previously saved data files. File | Device Setup Help
Save Saves data to hard disc. Load
Export Exports data in .txt format. =

Export
Export to JSON Exports data in JavaScript Object Notation.

Export JSON
Close Closes the current experiment.

Close
Close All Closes all open experiments. Close All
Exit Exits the program. Exit

MENU: Device — NOT ACTIVE FOR SP mini

Connect Detects and connects the device.

Update Firmware Used for firmware updates. File | Device | Setup Help
Connect [

Attach GPS File Used to download data from the GPS module of the old

Update Firmware

Attach GPS File

versions of the SpectraPen or PolyPen.

Memory Erase Erases data from the memory of connected device.
Memaory Erase
Online Control Online control of the device. Online Control
MENU: Setup
Update Software Used for software updates.
P P File  Device | Setup | Help
Settings On/off — Auto memory erase after download.

Update Software

Selection of separator for the csv file after its export Settings
and following opening in Excel (TAB, SEMICOLON,
COMMA, SPACE).

MENU: Help
Registration Used for the SpectraPen software registration. (@ SpectraPen
File Device Setu Hel
About Offers basic information about the program. ¥ d —
Registration
About
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4 DATA VISUALIZATION

1. Visualization modes: Scope mode window is always displayed as the default. To view irradiance data go to Irradiance tab (Fig. 4).

Scope mode represents non-calibrated spectrum.

o s

File Device Setup Help Data type menu Selection of shown

\J’g
)
B

Scope | iradi
Data download

l from SpectraPen l> Download 15000 > ) ¥jj1 mnsaeesrs I
W-\ Vi@ 2 115201810:47:09
: 30000 VI3 1152018104721
Openmgofd'ata ]I - / 7/\ \\\ \ @l 4 115201810:47:30
from local disc ™ 25000 VIl 5 115201810:50:18
20000 \\ \ \ VIl 6 1152018105135

/
/
It

Data saving in l
.spec format

W

A
\
\

List of measured

~\
=) (w1 =N
rmat . /JJ P \ UV

10000

;f\

| - /T
1

]

Data export in .txt 1

-5000
324 424 524 624 724
[nm]
Measure Data 1
SpectraPen ‘ 1301 | 6294 of 2097152 bytes used
Fig. 4 Scope spectra.

2. All data that are downloaded are displayed in the Scope window after download from the SpectraPen. The user can select the set
of measurements to be displayed by marking and unmarking the data from the selection list (Fig. 4).

3. Right click on list of measured data enables edit data name, delete selected measurement or show and hide all measured data in
the graph— Select all measure and Clear all measure (Fig. 5).

File  Device Setup Help

|| Seope | Imadiance
Donrios 25000

- 5000 VRS [VANRNE AN
] Ml Jf S AL
000 AN =N A

— 10000 /
- A

Select all measure

Clear all measure

Edit measure name

SEEEEE

Delete measure J

-5000
324 424 524 624 724
[nm]
Measure Data |
SpectraPen | 1301 | 6294 of 2097152 bytes used

Fig. 5 Options for list of data.
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4. In the graph marker feature is available, which enables display of the numeric values for wavelength and light irradiance for the
selected wavelength of the scan (Fig. 6). Use the mouse to select the given point. In top right corner of the graph (red rectangle) is
displayed exact value for the selected point on the x-axis and y-axis.

ﬁ SpectraPen L [m] X

File Device Setup Help

Scope Imadiance
Download = = F 1 03072018 1121:22
2 Ml 2  0307.201811:23:02
w/..] ME 3 03072018 11:23:14
4 (ers Ml 4 0307201811:28:34
s Y=2,551256 Fl 5 0908201882310
3 I \ Ml 6 0908201882345
T M 7 0908201882356
Save $ 2 [l l Ml & 09.082018824:10
8 ;X ‘ \ & 9 0908201882419
3 g ) A / =l 10 0908201882452
— 3 -
= N\ / 1\ \ M 11 09.08.20188:25:01
’ 2l B Relseoo &l 12 0908201882526
M@ 13 09.08.2018 8:26:07
-1

324 424 524 624 724

[nm]

C:\Users\Katerina\Desktop \test-data-ND spec

Device: Not Connected Version

Fig. 6 Marker feature.

5. Tozoom in on the data displayed in the graph select an area of the displayed graph (Fig. 7). To reverse these steps and return to
original display use minus icon in the corners of the zoom area marked with red rectangles in Fig. 7.

(@ SpectraPen - o X
File Device Setup Help
Scope radiance
Download 5803 = Ej 1 0307201811212
Yt Ml 2 03072018 11:23.02
v-1060 M3 0307201811:23:14
o Ml 4 0307201811:28:34
El 5 0908201882310
38831 X Pl 6 0908201882345
oo S, S [ 7 09.0820188:2356
Save X M8  09.082018824:10
N M 9 09082018824:19
18931 N B 10 0308201882452
Bxpor | M 11 0908201882501
o &l 12 09.08201882526
— e | 13 09.08.2018 8:26:07
-1069 - 5
465 485
[nm]
C:\Users\Katerina\Desktop \test-data-ND spec
Device: Not Connected Version |

Fig. 7 Zoom function.
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Select Irradiance tab to view the irradiance data stored either as umol/m2/s/nm or per uWatts/cm2/nm. To change the units in

which the spectra is displayed click on the unit icon as shown in (Fig. 8).
To view the light meter data for the spectral scans acquired click on the unit icon as depicted by red arrow in Fig. 8. Irradiance and
illuminance light meter numerical values for each scan are displayed as LUX, PAR or IRRADIANCE values (Fig. 9).

& = |
File Device Setup Help
) | [Scope] iradance |
Download [ : ] VIl 1 115201885735
12 w2 1152018104709
1 W) vl nsasioea
w4 5208104730
Ooen 08 /K \ wlls 15208105018
// \ @l 6 1152018105135
E 0.6
F o4
3 \
2 Y\
Epot ; =
02
324 424 524 624 724
[nm]
MeaanDaa|
SpectraPen | 1301 | 6294 of 2097152 bytes used |
7 =
File Device Setup Help
Download C» ] @ nsasess
20 — 2 nsas104709
/7(\ | b | “ll: nsasi0e21
15 @l 4 152018104730
Gen @5 15208105018
@is 152018105135

. NN

[WWWem2/nm]

5
324 424 524 624 724
[nm]
Measure Data I
SpectraPen | 1301 | 62940f2097152 bytes used |

Fig. 8 Irradiance shown in different units.

i = i
File Device Setup Help
Scope | Imadiance v
Download Time Name LUX PAR[UE] IRRjuW/cm2] 1 1152018 8:57:35
1152018 8:57:35 693261 |11788  |307.9139 Cwrt | 2 1nanEe
2 1152018 10:47:09 89458229 |111.7149  (2388.7603 > 4 1152018104730
Open 3 1152018 10:47:21 734029 (93186 198,649 5 1152018105018
4 115.2018 10:47:30 3658792 100546  |1935435 6 1152018105135
s 5 1152018 10:50:18 8088,8656 | 1465217  |3204,1899
5 1152018 10:51:35 4336436 67446 15,8966
Expott
MeasumDaal
SpectraPen | 1301 | 6294 0f2097152 bytes used |

Fig. 9 Numerical values of measured light intensities.
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8. To Save the experiment select File>Save. All data stored in the device memory will be saved irrespective of the data selection in
the SpectraPen software. The file will be stored as .spec. Spec files stores all Scope and Light meter data.

9. Select File>Export to export the data in .txt format. Export function allows the user to specify the type of data. The options are:
Spectrum (Fig. 10) — all raw scope data for entire range of measured wavelengths are exported including data for the dark scan.
Spectrum scope — scope data normalized to dark spectrum scan are exported for all acquired scans or set of selected
measurements.

Export NN X

What
@ Spectrum

) Spectrum Scope

) Spectrum Imadiance

) Computed Data

[7] Export Interpalation

[ Export H Cancel

Fig. 10 Export options.

Spectrum Irradiance —irradiance data for all measurements are exported. The user can choose to export the numeric values either
in LE/m2/s/nm, uW/cm2/nm or both (Fig. 11).

Export =RNN X

What
(") Spectrum
) Spectrum Scope
Choose Values

[LE/m2/5/nm]
@ Spectrum Imadiance [WW/em2/nm]

71 Computed Data

[7] Export Interpolation

[ Export ][ Cancel

k.,

Fig. 11 Export of Irradiance spectrum.

Computed Data — computed numeric values for Scope and Irradiance are exported for all measurements. The user can choose if
only Scope numeric values or Irradiance numeric values are exported. For irradiance values, numeric data for Photon flux density
and PAR in umol/m?2/s units, irradiance in uW/cm? units and illuminance in LUX units are exported (Fig. 12).
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Export interpolation — if this option is marked the spectrum is exported with step of 1 nm.
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-

Export

= | B - |

What
() Spectrum
(71 Spectrum Scope

@ Computed Data

[] Export Interpolation

[ Export ][ Cancel

Choose Values

Scope

Iradiance

LS

Fig. 12 Export of computed values.



5 TROUBLESHOOTING AND CUSTOMER SUPPORT

In case of problems with the SpectraPen SW visit FAQ on our websites (http://psi.cz/support/fag) or contact customer support by email
to support@psi.cz , or contact your local distributor.

6 APPENDIX

6.1 PROGRAMMING CUSTOM INDEX IN SPECTRAPEN

The SpectraPen software enables programming custom indexes, which can be used for wide range of calculation based on the measured
spectrum.

1. Go to the main SpectraPen folder in your PC (Usually in Program Files).
2. Open the file Config > Formulas.txt.
3. Write your index into this .txt file and save it (Fig. 13).

Index example:

Scope:PSlindex:PS| test index:Scope[600nm]/ Scope[500nm]

Scope —the index is placed in the bookmark Scope in data in the software

PSlindex — name of the index in the SpectraPen software and in exported data

PS| test index — full name of the index (not showed)

Scope[600nm]/ Scope[500nm] — equation for calculation; calculated from 500 and 600 nm of Scope spectra

“lIFormulas - Poznamkovy blok - u] x

Soubor Upravy Formit Zobrazeni Napovéda

Transmitance:NDVI:Normalized Difference Vegetation Index:(Transmitance[78@nm]-Transmitance[63@nm])/(Transmitance[788nm]+Transmitance[63@nm])
Transmitance:SR:Simple Ratio Index:Transmitance[780nm]/Transmitance[630nm]

Transmitance:MCART1:Modified Chlorophyll Absorption Ratic Index 1:1.2%(2.5%*(Transmitance[786nm]-Transmitance[676nm])-1.3*(Transmitance[78@nm]-Transmitance[556nm]))
Transmitance:0SAVI:Optimized Soil-Adjusted Vegetation Index:(1+@.16)*(Transmitance[78@nm]-Transmitance[67enm])/(Transmitance[78@nm]+Transmitance[67@nm]+8.16)
Transmitance:G:Greenness Index:Transmitance[554nm]/Transmitance[677nm]

Transmitance:MCART:Modified Chlorophyll Absorption Ratio Index:((Transmitance[7@@nm]-Transmitance[67@nm])-@.2*(Transmitance[7@8@nm]-Transmitance[558nm]))*(Transmitance
[7@Bnm]/Transmitance[676nm] )

Transmitance:TCART:Transformed CAR Index:3*((Transmitance[780nm]-Transmitance[670nm])-8.2*(Transmitance[788nm]+Transmitance[558nm])*(Transmitance[700nm]/Transmitance
[670nm]))

Transmitance:TVI:Triangular Vegetation Index:@.5*(120*(Transmitance[750nm]-Transmitance[55@nm])-20@*(Transnitance[670nm]-Transmitance[556nm]))
Transmitance:ZMI:Zarco-Tejada & Miller Index:Transmitance[75@nm]/Transmitance(718nm]

Transmitance:SPRI:Simple Ratio Pigment Index:Transmitance[438nm]/Transmitance[688nm]

Transmitance:NPQT:Normalized Phaeophytinization Index:(Transmitance[415nm]-Transmitance[435nm])/(Transmitance[415nm]+Transmitance[435nm])
Transmitance:PRI:Photochemical Reflectance Index:(Transmitance[531nm]-Transmitance[578nm])/(Transmitance[531nm]+Transmitance[570nm])
Transmitance:NPCI:Normalized Pigment Chlorophyll Index:(Transmitance[68@nm]-Transmitance[43@nm])/(Transmitance[68@nm]+Transmitance[43@8nm])
Transmitance:Ctrl:Carter Indices 1l:Transmitance[695nm]/Transmitance[420nm]

Transmitance:Ctr2:Carter Indices 2:Transmitance[695nm]/Transmitance[760nm]

Transmitance:Licl:Lichtenthaler Indices 1:(Transmitance[78@nm]-Transmitance[68@nm])/(Transmitance[78@nm]+Transmitance[&8@nm])
Transmitance:Lic2:Lichtenthaler Indices 2:Transmitance[448nm]/Transmitance[696nm]

Transmitance:SIPT:Structure Intensive Pigment Index:(Transmitance[78@nm]-Transmitance[458nm])/(Transmitance[78@nm]+Transmitance[656nm])
Transmitance:GM1:Gitelson and Merzlyak Indices 1:Transmitance[75@nm]/Transmitance[556nm]

Transmitance:GM2:Gitelson and Merzlyak Indices 2:Transmitance[75@nm]/Transmitance[7@enm]

Transmitance:ARI1:Anthocyanin Reflectance Index 1:1/Transmitance[550@nm]-1/Transmitance[7@@nm]

Transmitance:ARI2:Anthocyanin Reflectance Index 2:Transmitance[79@nm]*(1/Transmitance[55@nm]-1/Transmitance[7@@nm])

Transmitance:CRI1:Caroteniod Reflectance Index 1:1/Transmitance[518nm]-1/Transmitance[55@nm]

Transmitance:CRI2:Caroteniod Reflectance Index 2:1/Transmitance[51@nm]-1/Transmitance[76@nm]

Transmitance:RDVI:Renormalized Difference Vegetation Index:(Transmitance[78@nm]-Transmitance[678nm])/((Transmitance[780nm]+Transmitance[676nm])*@.5)
Irradiance:LUX:LUX:683*integral(Irradiancel, 36@nm,78@nm)

Irradiance:PAR[uE]:PAR[uE]:integral(IrradianceE, 4@@nm, 70@nm)

Irradiance:IRR[ull/cm2]: Irradiance[un/cm2]: integral(Irradiancel, 348nm, 78@nm)

Lonadi 188 MIRL ol Tonads i E LiZagadiancel, 646nm, 185@nm)
lS:npe:PSIindex:PSI test index:Scope[60@nm]/ S:ope[saanm]l

Fig. 13 New index in the Formulas file.

Restart the SpectraPen Software.
5. The new index appears in the selected bookmark in the data (Fig. 14).
6. For export of this index choose the option “Computed values” and selected spectrum in the export table.
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‘ SpectraPen

File Device

- O X
Setup Help I
Scope |radiance *
Index Time Name PSlindex 1 03.07.2018 11:21:22
2 03.07.201811:23.02
_ 03.07.2018 11:21:22 0.1398
3 0307.201811:23:14
2 03.07.2018 11:23:02 0.1246 4 0307.201811:28:34
3 03.07.2018 11:23:14 05444 5  09.08.20188:23:10
4 03.07.2018 11:28:34 06424 g g.g,zzg}: :;g;::
ol .08. :23:
5 09.08.2018 8:23:10 0.5049 &l e 0908201882410
3 09.08.2018 8:23:45 0.6869 M 9 0908201882419
7 09.08.2018 8:23:56 1,0829 B 0 0308201882452
24 11 09.08.2018 8:25:01
8 09.08.2018 8:24:10 1,1581 2l 2 0a08 2msazsos
9 09.08.2018 8:24:19 0.8928 13 09.08.2018 8:26:07
10 09.08.2018 8:24:52 86956
1 09.08.2018 8:25:01 237136
12 09.08.2018 8:25:26 28.7221
13 09.08.2018 8:26:07 34643

C:\Users\Katerina\Desktop ‘test-data-ND spec

Device: Not Connected Version

Fig. 14 New index.

6.1.1  FUNCTION DESCRIPTION

Different mathematical functions can be used in SpectraPen software syntax to create new custom formulas.

min, max -

min(valuel, value2)

valuel - number, variable, function

value2 — number, variable, function

- only one value can be function!

min(array)

array — array of numbers

examplel: max(Scope)

example2: min(Irradiance)

example3: min(Scope[760nm], max(Scope[450], Scope[680]))

example4: max(Irradiance[550nm], (5+4)*4)

In —the natural (base e) logarithm of specified number

In(value)

value — number, variable, function

examplel: In(5)

example2: In(Irradiance[760nm])
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example3: In(max(Irradiance [550nm], Irradiance[480nm]))

exampled4: In((5+4)*4)

log — the logarithm of specified number in a specified base.
logB(value)
B — base - number

value — number, variable, function

examplel: log2(5)
example2: log5(Scope[760nm])
example3: log10(max(Scope[550nm], Scope[480nm]))

exampled: log10((5+4)*4)

sqrt — the square root of a specified number
sqrt(value)

value — number, variable, function

examplel: sqrt(5)
example2: sqrt(Scope[760nm])
example3: sqrt(max(Scope[550nm], Scope[480nm]))

exampled: sqrt(((5+4)*4) + 6)

A - specified number raised to the specified power
value*power
value — number, variable, function

power — number, variable, function

examplel: Irradiance[760nm]* Irradiance[550nm]
example2: min(Irradiance[760nm], Irradiance[550nm])*max(Irradiance[435nm], Irradiance[430nm])

example3: Transmitance[760nm]*0.5

integral - express the area under the curve of a graph of the function in the interval
integral(function_values, from, to)
function_values — input values for integral compute

from,to — limit values
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examplel: integral(lrradiancel, 360nm, 700nm)

example2: integral(lrradianceE, 360nm, 700nm) * IrradianceE[450]
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