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1 ABOUT THIS MANUAL 

Read this manual carefully before operating the device. If you are not sure about something in the manual, contact the 
manufacturer for clarification. 

Always follow corresponding manuals while working with the SpectraPen device or doing the maintenance. It is forbidden to 
interfere with the hardware or software of the SpectraPen device in any way without previous agreement with the 
manufacturer. 

The following table presents basic highlight symbols used in this manual: 

Symbol Description 

 

Important information, read carefully. 

 

Complementary and additional information. 

Table 1 Used symbols. 
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2 GENERAL INFORMATION 

2.1 DEVICE DESCRIPTION  

SpectraPen LM 510 is a handheld portable spectroradiometer that is ideal as a general-purpose instrument for research and 
for agricultural applications. The built-in rechargeable Li-Ion battery, GPS module and splash-proof case make the device ideal 
for outdoor use. The device is well suited for wide scope of environmental, agricultural and ecological applications such as 
monitoring of artificial lighting used in horticulture industry or light source testing. 

SpectraPen LM 510 measures in radiometric or photometric units intensity of electromagnetic radiation and is calibrated for 
visible light in the range of 340 – 790 nm or for radiation in the range of 640 – 1,050 nm. The intensity can be measured 
qualitatively as a spectrum intensity profile or quantitatively as intensity in a defined range of spectrum. When measuring in 
visible light the device also measures light color and color temperature parameters.Each SpectraPen device is calibrated with 
the certified light source AvaLight - DH-BAL-CAL. Spectrapen calibration certificates are provided upon requests from individual 
customers. The detector integration time can adjust automatically according to the ambient light intensity.When connected to 
a computer several additional control and data management become available.  

The SpectraPen device is switched ON or OFF with the power button (Fig. 1) and is controlled via color touch display and a 
stylus. The optical sensor on top of the device has two versions: in horizontal version the cosine corrector is on the display side 
and in vertical version the cosine corrector is on top of the optical head. For recharging or controling the device via computer 
the device is connected to the connector at the bottom side of the device.  

 

Fig. 1 LM 510-H device description 

 
The sensor should be always clean and protected when not in use. Any scratches on the surface might 

interfere with the measurement. 
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No sharp objects should be used when operating the SpectraPen via touch screen. It is recommended to 

use the provided stylus when making selections on the touch screen. 

2.2 SPECTRAPEN VERSIONS 

The UVIS version was designed for measurements in the visible part of the spectrum (range 340 – 790 nm) and the NIR version 
for spectrum range 640 – 1,050 nm. Depending on the device version the cosine corrector is mounted on the display side of 
optical head (horizontal version) or on top of the optical head (vertical position). 

LM 510-H/UVIS 

(Fig. 2A) 

Horizontal version for use in limited space 

Cosine corrector is on the display side, wavelength range 340 – 790 nm 

LM 510-H/NIR 

(Fig. 2A) 

Horizontal version for use in limited space  

Cosine corrector is on the display side, wavelength range 640 – 1,050 nm 

LM 510-V/UVIS 

(Fig. 2B) 

Vertical version for use in open field or greenhouse with tripod mount 

Cosine corrector on the top of the optical head; wavelength range 340 – 790 nm 

LM 510-V/NIR 

(Fig. 2B) 

Vertical version for use in open field or greenhouse with tripod mount 

Cosine corrector on the top of the optical head; wavelength range 640 – 1,050 nm 

 

 

Fig. 2 A) SpectraPen LM 510-H. B) SpectraPen LM 510-V 
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2.3 LIST OF EQUIPMENT AND CUSTOMER INFORMATION  

Standard version of the SpectraPen device package contains: 

• SpectraPen 

• Carrying Case 

• Textile Strap for Comfortable Wearing 

• SpectraPen Operating Manual and software (on a USB flash disc) 

• USB cable 

• Stylus 

• Other Accessories or Optional Features (according to your specific order) 

 

In case an item is missing, please, contact the manufacturer. Also check the carton for any visible external damage. 

If any damage is found, notify the carrier and the manufacturer immediately. The carton and all packing materials 

should be retained for inspection by the carrier or insurer. For customer support, write to: support@psi.cz 

2.4 MEASURED PARAMETERS 

SpectraPen is especially useful for rapid measurements of spectral light quality and quantity in radiometric or photometric 
units. 

Scope as spectrum intensity profile as Irradiance [µW.cm-2.nm-1] or Photon flux density [µmol.m-2.s-1.nm-1] 

Light intensity in defined range of the spectrum. The range can be adjusted by the user. Four calibrations are available  

• Irradiance [W.m-2] in user defined range of the electromagnetic spectrum 

• Photon flux density [µmol.m-2.s-1] in user defined range of the electromagnetic spectrum 

• Illuminance [Lux] - total luminous flux incident on a surface, per unit area 

• PAR [µmol.m-2.s-1]* 

Chromaticity Diagram CIE1931 - quality of color space and color temperature of the light source 

• CIE color coordinates* 

• Correlated color temperature – for LED * 

• Color rendering index 

* Valid only for LM 510-UVIS version of SpectraPen LM 510 

2.5 TECHNICAL SPECIFICATION 

Spectral range 
340 nm – 790 nm (LM 510 UVIS) 

640 nm – 1050 nm (LM 510 NIR) 

Spectral response half width 9 nm 

FWHM bandwidth 7 nm 

Wavelength reproducibility +/- 0.5 nm 

Spectral Straylight -30 dB 

Integration time from 5 ms to 10 s, set automatically 

Number of pixels 256 

Dimension of pixel 0.5 x 15.8 mm 

Internal memory capacity Up to 16 Mbit 

Internal data logging Up to 4,000 measurements  

Data transfer USB cable 

PC software SpectraPen 1.1.0.22 (Windows 10 or higher) 

Battery type Li-Ion rechargeable battery 

mailto:support@psi.cz
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Battery capacity 2,600 mAh 

Max. charging current 0.5 A 

Charging Via USB port - PC, power bank, USB charger, etc. 

Battery life 300 - 500 measurements until low battery indication 

Optical entrance Cosine corrector 

Display Touchscreen 240 x 320 pixel; 65535 colors 

Built in GPS module 
Ultra-high sensitivity down to -165dBm 

High accuracy of <1.5 m in 50 % of trials 

Size 180 x 75 x 40 mm 

Weight 300 g 

Operating conditions 
Temperature: 0 to +55 °C 

Relative humidity: 0 to 95 % (non-condensing) 

Storage conditions 
Temperature: -10 to +60 °C 

Relative humidity: 0 to 95 % (non-condensing) 

2.6 MAINTENANCE AND CLEANING  

• The device should not come in contact with any organic solvents, strong acids or bases  

• The device water protection qualifies as splashproof, do not submerge the device in water 

• Do not use sharp objects for controlling touch display 

• Keep the cosine corrector clean and dry 

• To prolong battery lifespan do not store the device completely discharged or fully charged and avoid extreme 
temperatuires 

Clean the surface witch soft and wet non-abrasive tissue. For cleaning the whole top chamber with clip can be removed. 
Unscrew the bolts on the optical head and wipe the inner surfaces carefully with a wet cloth or cotton bud.   

 

Recalibrating the device at least once every two years to maintain optimal performance is recommended.  
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3 GETTING STARTED 

3.1 CHARGING DEVICE WITH USB CABLE 

SpectraPen comes with a USB cable that is required for charging the battery. The same cable is also used for data transfer to  
a PC after measurement. To connect physically the USB cable to the SpectraPen device follow the picture instructions below. 
Please note that a lock in system is used to secure the USB cable to the SpectraPen and extreme caution has to be used when 
setting up this connection to avoid damage to the cable pins.  

 

When connecting the USB cable take extra caution to prevent damage to the cable connector pins.  Ensure 

correct orientation of the cable as shown in the pictures below so the circled portion of the plug and the cable in 

photo A and B are perfectly lined up prior to pushing them together. Once this connection is achieved the cable 

may be secured in position by turning the metal cover of the cable and locking the cable in position. 

1. Take the round connector end of the provided USB cable  

2. Insert the round connector end to the round USB socket at the bottom of the device (Fig. 3A-D). 

3. Screw and tighten the connector on the cable side (Fig. 3E-F). 

4. Connect the other end of the USB cable to a PC, power bank or a USB charger 

5. The device starts to charge automatically  

6. When switched OFF large charging icon appears on the device display. When ON the battery icon on the display (Fig. 
4) indicates the actual charge status.   

 

Fig. 3 Picture instructions on how to connect the USB cable to the Spectrapen.A) connector on the SpectraPen device. B) Portion of the USB cable 
with pins. C – E) Position the cable horizontally and line up the green circled parts of the cable and the connector, plug in the inlet and screw the 
securing screw. F) Correct connection of the USB cable and Pen device. 
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Fig. 4 Battery status indicator showing battery status: discharged A, charged B  

 

Before starting a series of mesurements ensure the device is fully charged.  When fully charged a maximum of 

500 measurements can be done. Avoid using the device with discharged battery (red icon) 

The device is switched OFF by pressing the power button again and confirming the dialog on the display by OK button. 
Alternatively holding the power button for 2 seconds can also switch the device OFF. 

 

In case the device has Button measure enabled switching the device OFF is possible only by pressing and 

holding the power button for 2 seconds. 

3.2 DARK SPECTRUM CALIBRATION 

Take the dark spectrum reading everytime the device is switched ON or before each series of measurements. The dark spectrum 
scan is equivalent to zeroing the instrument and no readings can be taken without this step. 

1. Select Get Dark Spectrum -> tap OK (Fig. 5). 

2. Cover the cosine corrector and tap OK (Fig. 5). Use dark cloth to ensure that the cosine corrector is covered 
completely. No ambient light should reach the detector during calibration. 

3. Wait until Getting dark spectrum changes to Dark spectrum saved. 

4. The Dark spectrum calibration step is completed and automatically stored in device memory. For future 
measurements the dark spectrum calibration scan is normalized to the surrounding temperature and relative to the 
detector integration time.  

 

Fig. 5 Dark spectrum calibration 

 

In case surrounding temperature is rapidly changed during the calibration step or during the measurement, the 

SpectraPen will automatically ask for new dark spectrum calibration. 
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3.3 MEASUREMENT 

1. Select a type of measurement under Measure menu (Fig. 6). Three options exist: Scope is spectrum intensity profile 
quantified as Irradiance [µW.cm-2.nm-1] or Photon flux density [µmol.m-2.s-1.nm-1] Light intensity is total intensity 
value in a spectrum range defined in the Options settings. Chromaticity diagram is light color and correlated color 
temperature (CCT). 

2. Position the device the cosine corrector level should be perpendicular to the light source. 

3. Tap the Get Spectrum button. Hold the device until the Spectrum Saved allert appears. If the Button measure feature 
is enabled optional use of ON/OFF button instead of tapping Get Spectrum button is enabled.  

4. Confirm the Spectrum Saved ID# ** allert with OK button. The ID number is unique for the actual series of 
measurement. The actual (last) measurement can be erased in Data -> Erase last.   

 

Fig. 6 Selecting type of measurement 

 

Each reading is stored with a unique ID irrespective of erasing a measurement. After erasing the last reading 

the erased ID is not reused for a next measurement. This applies when erasing measurements in the 

Spectrapen software after data download.      
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4 DISPLAY MENU 

4.1 MEASURE  

4.1.1 SCOPE 

Scope is spectrum intensity profile quantified as Irradiance [µW.cm-2.nm-1] or Photon flux density [µmol.m-2.s-1.nm-1]. 

To take the Scope measurement select Scope in the Measure menu (Measure -> Scope -> Get Dark Spectrum/Get Spectrum). 
The spectrum data is stored to the device memory, dark current is subtracted and and displayed in a graph.  

 
Select the units displayed on the graph in Options -> Settings. 

4.1.2 LIGHT METER 

The light meter is used for measurements of light intensity at defined range of wavelengths (Fig. 7).  

Three calibrations are available: 

1) Irradiance [W.m-2] in user defined range of the electromagnetic spectrum  
2) Photon flux density [µmol.m-2.s-1] in user defined range of the electromagnetic spectrum  
3) Iluminance [Lux] - total luminous flux incident on a surface, per unit area  

To take the measurement, select Light Meter in the Measure menu (Measure -> Light Meter -> Get Spectrum). 

Light intensity of the light source is displayed and stored to the device memory.  

The Light Meter integrates the value based on the wavelength range defined. For LM 510/UVIS this is in range 340-780 nm. The 
user can redefine the wavelength range in the Options -> Settings -> Graph section. To measure photosynthetically active 
radiation (PAR) change the settings to 400 to 700 nm.  

 

Fig. 7 Light meter screen 

4.1.3 CHROMATICITY DIAGRAM  

Chromaticity diagram is used for determination of light color and correlated color temperature (CCT) using the International 
Commission on Illumination (CIE) techniques (Fig. 8). All light colours can be uniquely identified standard coordinates of the 
1931 CIE colorimetric system.  A color space is a uniform representation of visible light. It maps all of the colors visible to the 
human eye onto an x-y grid and assigns them measureable values. This allows us to make uniform measurements and 
comparisons between colors. 

To perform the measurement, select from the top menu of the main screen: Measure -> Chromaticity diagram -> Get Spectrum  

The color of the light source in the CIE1931 colorimetric system is marked by black cross. The x- and y- coordinates of the 
measured light source will be determined and the CCT value will be calculated and displayed on the screen. The CCT values are 
not stored automatically. 
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Each measurement gives the folowing parameters: 

• CIE1931 color coordinates * 

• Correlated color temperature - for LED * 

• Color rendering index 

* Valid only for LM 510-UVIS version of SpectraPen LM 510 

 

 

 

 

 

 

 

 

 

 

Fig. 8 Chromaticity diagram 

4.2 DATA MANAGEMENT 

In Data menu 4 options are available (Fig. 9):  

Browse displays data browse dialog box. The user can browse the list of data in two tables: Scope and PAR. Each row starts 
with the unique ID number followed the date and time of measurement. In the Scope table the readings selected in the 
checkbox in the column on the right side the data can be viewed in a graph on the display. In the PAR table PAR intensity values 
are shown on the right side.  

Memory info displays info on current status of device memory 

Erase all is used to erase internal data memory  

Erase last marks the actual (last) reading as invalid and removes the reading from the data table  

 

Fig. 9 A. Data menu and B. Data browse 
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4.3 OPTIONS 

Select Options -> Settings to open the Settings table (Fig. 10). The table menu contains four settings groups. 

4.3.1 GRAPH  

Graph displays options for setting the wavelength range and graph features (Fig. 10A) 

Zoom enable – enables the zoom feature. Select a rectangle by moving the stylus over the graph obliquely in left to right 
direction. To zoom out back repeat the movements in right to left direction. 
Marker enable – enables to display exact numeric value for the point selected in the Scope graph window. Exact wavelength 
and light irradiance are displayed for the point touched on the graphical display. In top right corner of the LCD display the exact 
value of wavelength in nm is displayed for the user selected position of the spectrum. In addition, light irradiance for the given 
nm is shown.  
Smoothing – enables noise reduction of the graphical display by Smoothing the noise in the spectrum at the expense of spectral 
resolution. 
Wavelength range – defines the range of wavelengths considered for light meter measurements of Irradiance and Photon flux 
density. Desired wavelength range can be adjusted by selecting the wavelength and by using the arrows up and down.  
 

 

Fig. 10 A) Graph settings B) Time setting. 

 

The wavelength range setting applies only to the light meter mode of measurement and for direct viewing or 

browsing the intensity values in the Spectrapen. For data upload the device allways saves the whole spectrum 

and the light intensities are calculated from the whole spectrum. 

 
The wavelength range setting is not active for Illuminance. 

4.3.2 TIME 

The time feature is used to date all measured data. To set the time and date use the up and down arrows on the right side of 
the settings window (Fig. 10-B). 

4.3.3 LCD 

Two parameters can be adjusted on the LCD display (Fig. 11-A): 

Backlight intensity – move slider to adjust back light intensity in percentage 

Backlight time-out – move slider to adjust backlight time-out between 5 and 60 s (time of inactivity required before backlight 
will dim out to save battery life). 
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4.3.4 DEVICE 

The Options - > Device menu has 3 items (Fig. 11) 

GPS enable activates the GPS built-in module. The GPS coordinates cannot be displayed on the device display, but they are 
exported together with data and visualized in SpectraPen software on the computer after download.  

Button measure The power ON/OFF button can be used for taking measurements same way as the software Get Spectrum 
button. 

Average –Average function is used for adjusting the number of scans for each reading. Averaging of more scans results in a 
higher signal-to-noise ratio but increases the time required for each reading that appears on the screen. Move slider to set the 
number of measurements to be acquired for averaged values.  

 

          

Fig. 11 LCD settings                                          Fig. 12 Device settings 

4.4 HELP 

In the Help menu select About… to view information about the device 

• name and type  

• serial number  

• hardware version  

• software version  

4.5 USB DRIVER UPDATE  

In case of any connection problems first check that the USB cable is properly connected (for instructions see paragraph 3.1., 
page 12). 

 
Updating the USB driver is not required if the SpectraPen package installation was completed sucessfully. 

 If the problem persists update the USB driver with these steps: 

1. Insert the USB stick provided with the device to a PC and copy the Software -> driver folder to the PC 

2. Press Windows Start and Select Device Manager (Fig. 13) 

3. Connect the SpectraPen device to the PC and switch the device ON 

4. In the Device Manager find Ports (COM & LPT) and right click the item 

5. Select Update Driver 
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Fig. 13 Device Manager icon in the Wíndows Start menu and the detected USB Serial Device with options 

6. Select Browse my computer for driver software  

7. In the next window select the Software - > Driver folder copied from the USB stick (Fig. 14, Fig. 15) 

8. In case a warning message appears click Allow the installation procedure 

9. Installation of the driver is complete.  USB connection icon appears on the SpectraPen device display (Fig. 16).  

 

 

Fig. 14 Choose the driver from the USB disc.  
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  Fig. 15 Browse for Drivers and Update completed windows  

 

Fig. 16 Icon on the SpectraPen device display indicating the USB connection. 
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5 SPECTRAPEN SOFTWARE  

5.1 SOFTWARE PREPARATION 

5.1.1 SW INSTALLATION   

To download data from the device install SpectraPen software on a computer that runs on a Microsoft Windows Operating 
System. The software installation is done automatically by executing the SpectrapenPenPackageInstaller.exe file. 

1. Insert the provided USB stick to the computer or download the file from PSI web page (“Software” section)  
https://psi.cz/support/downloads/hd001/spsp001/ 

2. Find the downloaded file in the Software folder on the USB stick or open the Downloads folder  

3. Run the installer file by left clicking the exe file (Fig. 17).  

   

Fig. 17 Installer exe file icon 

4. The SpectraPen Package installation wizard opens. Proceed through the steps as is shown in Fig. 18. 

5. When completed the Spectrapen app is stored locally (C:\Program Files (x86)\PSI\Spectrapen by default), the USB 
driver is up to date and a shortcut icon for the SpectraPen app appears on the desktop. 

 

Fig. 18 Spectrapen installation procedure 
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5.1.2 ESTABLISHING COMMUNICATION 

1. Connect the device with USB cable 

2. Switch the device ON by pressing the power button 

3. Open the Spectrapen application by clicking the Spectrapen.exe file in the PSI\Spectrapen folder 

4. In the Spectrapen app go to Device –> Connect. The software searches for the device and indicates 
the status on the bottom bar of the window. This step usually takes several seconds.  

 

Fig. 19 Connecting the Spectrapen software 

5.1.3 DEVICE REGISTRATION 

To enable downloading feature in the SpectraPen software proceed with device registration (Fig. 20).  

1. Open a text file Registration code.txt in the Software folder on the USB stick provided with the device 

2. Select Help -> Register and enter your registration number  

3. Click Register, the SpectraPen Download button activates with the registration. 

 

Fig. 20 Software registration. 

 

Software registration is requried for downloading data from the SpectraPen device. 
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5.2 MAIN MENU 

5.2.1 FILE 

Load    Loads previously saved data files. 

Save    Saves data to hard disc. 

Export    Exports data in .txt format. 

Export to JSON  Exports data in JavaScript Object Notation. 

Close    Closes the current experiment. 

Close All   Closes all open experiments. 

Exit     Exits the program. 

5.2.2 DEVICE  

Connect   Detects and connects the device. 

Update Firmware Reinstall device software  

Attach GPS File  Download data from the GPS module 9 (applies to SpectraPen LM 500). 

Memory Erase   Erases data from the SpectraPen memory. 

Online Control  Online control of SP device. 

5.2.3 SETUP 

Update Software Activates when a new version of 
Spectrapen software is available online 

Settings  On/Off – Auto memory erase after 
download.  Selection of separator for 
the csv file after its export and following 
opening in Excel (TAB, SEMICOLON, 
COMMA, SPACE). 

5.2.4 HELP 

Registration  Used for device registration.  

About    Offers basic information about the program. 

  

5.3 DATA MANAGEMENT 

5.3.1 DATA DOWNLOAD AND VISUALIZATION 

Connect the device to a PC for data download and further analysis. 

1. Switch the device ON  

2. Start the SpectraPen software. In the Device menu select Connect. 

3. When connected upload data with the Download button or select Load in the File menu. 

4. All data stored currently in the SpectraPen device will be uploaded and shown in the main window view. The data are 
store and displayed/listed with the time stamp of measurement.  

5. Scope mode window is always displayed by default. To view irradiance data, select the Irradiance tab (Fig. 25). 

Fig. 21 Menu File. 

Fig. 22 Menu Device. 

Fig. 24 Menu Help. 

Fig. 23 Menu Setup and Settings options 
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6. All data that are downloaded are displayed in the Scope window after download from the SpectraPen. The user can 
select the set of measurements to be displayed by marking and unmarking the data from the selection list (Fig. 25). 

 
Please note that if there are no data stored in the memory, the download function is not active. 

 
Scope mode represents non-calibrated spectrum. 

 

Fig. 25 Scope spectra 

7. Right click on the list of measured data to edit data name, delete selected measurement or show and hide all 
measured data in the graph– Select all measure and clear all measure (Fig. 26). 

 

Fig. 26 Options for list of data 

8. In the graph marker feature is available, which enables display of the numeric values for wavelength and light 
irradiance for the selected wavelength of the scan (Fig. 27). Use the mouse to select the given point. In top right 
corner of the graph (red rectangle) is displayed exact value for the selected point on the x-axis and y-axis.  
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Fig. 27 Marker feature. 

9. Select Irradiance tab to view the irradiance data stored either as µmol.m-2.s-1.nm-1 or per µW.cm-2.nm-1 . To change 
the units in which the spectra is displayed click on the unit icon on the right side of the graph. 

10. To view the light meter data for the spectral scans acquired click on the unit icon as depicted by red arrow in Fig. 28. 
Irradiance and illuminance light meter numerical values for each scan are displayed as LUX, PAR or IRRADIANCE 
values (Fig. 28). 

 

Fig. 28 Numerical values of measured light intensities. 

11. To Save all data stored in the device select File > Save and create a name and path for storing a binary .spec file. This 
file can be later reopened in the Spectrapen software. All data stored in the device memory will be saved irrespective 
of the data selection in the SpectraPen softwareData Export. 

12. To export data File->Export. The Export window allows to select which type of data should be exported (Fig. 29). 

Raw Data raw data only, along with light readings dark current readings are exported  

Scope light intensities with dark current subtracted, no calibration to irradiance units    

Irradiance dark current subtracted and calibrated to 1) Irradiance [µW/cm2/nm] µmol.m-2.s-1.nm-1 and/or Photon Flux 
Density [µmol/m2/s/nm] (Fig. 29).  

Computed Data The export of computed data is based on the editable formulas.txt file. Two types of computed data 
can be exported: Scope using intensities at individual wavelengths or Irradiance with intensities based on integration 
(Fig. 29B).  
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Export interpolation –intensity profiles of measured bands are recalculated to 1 nm wide bands. For each 
measurement the device interpolates the reflectances measured at bands (e.g. 528.3, 530.2, 532,533.9,..) to distinct 
wavelength lengths defined by whole numbers (e.g. 528, 529, 530, 531,…). 

13. In the Export window click Expor. In the Export File Settings window (Fig. 29C) select data and file type.  

 

Fig. 29 Export options 

5.3.2 EXPORT OF COMPUTED DATA  

Choose the option “Computed values” and selected spectrum in the export table. 

5.3.3 PROGRAMMING CUSTOM INDEX  

The SpectraPen software enables programming custom indexes, which can be used for wide range of calculation based on the 
measured spectrum.  

1. Open the SpectraPen folder in your PC. Usually the program installs in the Program Files folder (C:\Program Files 
(x86)\PSI) 

2. Open Formulas.txt file located in Config folder (C:\Program Files (x86)\PSI\Spectrapen\Config) 

3. Write your index into the .txt file The text file Formulas.txt can be edited to create formulas for different light 
intensity or light index calculation. The newly defined formulas can be created based on predefined template 
formulas (see the text in red). When editing new formulas follow a few rules summarized in the appendix of this 
manual on page 32.  

Irradiance:LUX:LUX:683*integral(IrradianceL,360nm,780nm) 

Irradiance:PAR[umol/m2/s]:PAR[umol/m2/s]:integral(IrradianceE, 400nm, 700nm) 

Irradiance:IRR[uW/cm2]:Irradiance[uW/cm2]:integral(IrradianceW, 340nm, 780nm) 

Irradiance:IRR_NIR[uW/cm]:Irradiance[uW/cm2]:integral(IrradianceW, 640nm, 1050nm) 

Irradiance:R/FR ratio:Red-to far-red ratio:integral(IrradianceE, 650nm, 670nm)/ 

integral(IrradianceE, 720nm, 740nm) 

Scope:PSIindex:PSI test index:Scope[600nm]/ Scope[500nm] 

Irradiance: or Scope defines the field in which the index is used. In Scope only formulas calculating intensity ratio at two 
wavelength cane be calculated. In Irradiance only integration of light intensity in defined range can be used. 

PSIindex: or R/FR ratio: short name of the index displayed in the SpectraPen software and in the exported data 

PSI test index or Red-to far-red ratio: Full name of the index, is not displayed or exported 

Scope[600nm]/ Scope[500nm]: or Integral(IrradianceE, 650nm, 670nm)/integral(IrradianceE, 720nm, 740nm) are the 
actual formulas for index calculation 

4. Save the txt file and restart the SpectraPen Software 

5. The new index is displayed in the SpectraPen software (Fig. 30, red rectangles). Select Irradiance or Scope bookmark 
in the main window (Fig. 30-1) and switch to the data sheet with the << button (Fig. 30-2).  
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Fig. 30 Names of newly defined indices appear in the Irradiance or Scope tables  
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5.4 ONLINE CONTROL 

Menu Online Control 

This function can be used for remote - online control of the SpectraPen device after connection with the PC. Online control 
enables to make changes in device setting and also perform remote measurement using PC.  

Select: Menu > Device > Online Control (Fig. 31) 

Remote measurement (Fig. 32) 

Using this function Irradiance, Photon flux density and PAR can be measured.  

• For manual remote measurement click on Get button.  

• Setting for automated remote measurement is possible using the button 
with three dots (next to “Get” button in the window of the software). 
Here the time interval of the measurement is set. To apply this setting 
use the option Use settings (in “Settings Form” window) and confirm by 
clicking OK. The measurement stars immediately and continues until it is 
manually stopped (Stop button).  

• Use the export option for exporting the data to .csv file. 

• Clear function serves for erasing of data measured by Online Control. 

 

Please note that the Dark Spectrum Calibration should be done manually prior to the measurement. 
Otherwise error allert ID:1 appears. 

 

Fig. 32 Remote measurement. 

Settings (Fig. 33) 

Here the following functions may be set up for remote operation of the SpectraPen: 

• Time synchronization of the device and PC 

• GPS built-in module activation 

• Averaging of measurement (1 – 10 measurements) 

• Selection of the wavelength range for measurements  

• Integration time (0 – 10 s) 

Fig. 31 Online control. 
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Fig. 33 Online control settings. 

5.5 FIRMWARE UPDATE 

Update of the device firmware is done upon manufacturer's request. To update the firmware upload a FW file provided by PSI.   

 

All data in the SpectraPen memory are erased during the firmware update! 

Incompatible firmware version can cause device malfunction. 

1. Connect the device  

2. In the SpectraPen main menu Select: Setup -> Update Firmware From File 

3. Select the provided .bxn file and click Open. 

4. Select: OK to upload of the update. The bottom bar indicates the progress (Fig. 34) 

 

Fig. 34 Firmware update running. 
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6 GPS MODULE 

SpectraPen device LM 510 allows to access to location and timing signals from satellites. The integrated GPS module can be 
switched on for geotagging the readings with with accuracy around 4 meters. When measuring with activated GPS module 
geographic coordinates are automatically saved and can be displayed or later downloaded with the readings. 

 

For proper function of the GPS module accurate time settings in the SpectraPen device and rthe computer is 

necessary. 

MEASURING WITH GPS 

1. Check the time setting on the SpectraPen device: Settings > Date & Time 
2. Switch the GPS module “ON” on the SpectraPen device by following these steps in the SpectraPen menu: 

• Select: Options > Settings > Device  

• Click on the check box for GPS (Fig. 35) 

• Wait until the position flag icon in the upper menu stops flashing (Fig. 35). You may need to move to open 
space area to accquire sattelite signal  

3. Perform measurements  
4. Connect the SpectraPen to the computer and in the SpectraPen software download the measured data. Example of 

data tagged with GPS coordinates is shown in Fig. 36. 

 

Fig. 35 Activation of GPS 

 

Fig. 36 Data tagged with GPS coordinates.  
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7 WARRANTY AND SERVICE SUPPORT  

7.1 WARANTY TERMS AND CONDITIONS 

This Limited Warranty applies only to the SpectraPen device. It is valid for one year from the date of shipment.  

If at any time within this warranty period the instrument does not function as warranted, return it and the manufacturer will 
repair or replace it at no charge. The customer is responsible for shipping and insurance charges (for the full product value) to 
PSI. The manufacturer is responsible for shipping and insurance on return of the instrument to the customer.  

No warranty will apply to any instrument that has been (i) modified, altered, or repaired by persons unauthorized by the 
manufacturer; (ii) subjected to misuse, negligence, or accident; (iii) connected, installed, adjusted, or used otherwise than in 
accordance with the instructions supplied by the manufacturer.  

The warranty is return-to-base only and does not include on-site repair charges such as labor, travel, or other expenses 
associated with the repair or installation of replacement parts at the customer's site.  

The manufacturer repairs or replaces faulty instruments as quickly as possible; the maximum time is one month.  

The manufacturer will keep spare parts or their adequate substitutes for a period of at least five years.  

Returned instruments must be packaged sufficiently so as not to assume any transit damage. If damage is caused due to 
insufficient packaging, the instrument will be treated as an out-of-warranty repair and charged as such.  

PSI also offers out-of-warranty repairs. These are usually returned to the customer on a cash-on-delivery basis.  

Wear & Tear Items (such as sealing, tubing, padding, etc.) are excluded from this warranty. The term Wear & Tear denotes the 
damage that naturally and inevitably occurs as a result of normal use or aging even when an item is used competently and with 
care and proper maintenance.  

7.2 PRODUCT AND CONTACT INFORMATION  

Name of product SpectraPen LM 510 

Manufacturer PSI (Photon Systems Instruments, spol. s r. o.)   

Address Prumyslova 470, 664 24 Drasov  

Country of Origin Czech Republic   

7.3 TROUBLESHOOTING AND CUSTOMER SUPPORT 

For information about the device  

− visit our web page at https://handheld.psi.cz/products/spectrapen-lm/  

− contact your local distributor  

− send an email to info@psi.cz. 

In case of problems with the device or Spectrapen software 

− review our FAQs at https://handheld.psi.cz/faqs/#general-questions or 
https://handheld.psi.cz/faqs/#spectrapen-lm 

− contact your local distributor or  

− send an email to customer support at support@psi.cz. 

   

mailto:info@psi.cz
mailto:support@psi.cz
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8 APPENDIX 

List of syntax rules for programming new indices in SpectraPen software 

Min, max – minimum or maximum value 

min(value1, value2) where value1 or value 2 is a number, variable, function 

min(array) where array is an array of numbers  

example1: max(Scope)  

example2: min(Irradiance)  

example3: min(Scope[760nm], max(Scope[450], Scope[680])) 

example4: max(Irradiance[550nm], (5+4)*4) 

__________________________________________________________________________ 

ln – natural logarithm with base e  

ln(value) where value is a number, variable, function 

example1: ln(5) 

example2: ln(Irradiance[760nm]) 

example3: ln(max(Irradiance [550nm], Irradiance[480nm])) 

example4: ln((5+4)*4) 

__________________________________________________________________________ 

log – logarithm with base definition. 

logB(value) where value is a number, variable, function and B is base number 

example1: log2(5) 

example2: log5(Scope[760nm]) 

example3: log10(max(Scope[550nm], Scope[480nm])) 

example4: log10((5+4)*4) 

__________________________________________________________________________ 

sqrt – the square root of a number 

sqrt(value) where value is a number, variable, function 

example1: sqrt(5) 

example2: sqrt(Scope[760nm]) 

example3: sqrt(max(Scope[550nm], Scope[480nm])) 

example4: sqrt(((5+4)*4) + 6) 

____________________________________________________________________________ 

^ - exponentiation of a base raised by exponent (power) 

value^power where value is a number, variable, function and power is a number, variable, function 

example1: Irradiance[760nm]^ Irradiance[550nm] 

example2: min(Irradiance[760nm], Irradiance[550nm])^max(Irradiance[435nm], Irradiance[430nm]) 

example3: Transmitance[760nm]^0.5 

___________________________________________________________________________ 
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integral - express the area under the curve of a graph of the function in the interval 

integral(function_values, from, to) where from,to are limit values and function_values are input values for integral compute 

example1: integral(IrradianceL, 360nm, 700nm) 

example2: integral(IrradianceE, 360nm, 700nm) * IrradianceE[450nm] 
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